Schaltplan (Tutorial)

www.CAD6.de

 

 

Inhalt

In diesem Beispiel geht es darum, den praktischen Einsatz von Bibliotheken in einer Zeichnung zu üben. Sie werden das Erstellen einer neuen Bibliothek erlernen, Elemente zur Bibliothek hinzufügen und bearbeiten. Außerdem werden Techniken bei der Arbeit mit einfachen Grundrastern vorgestellt. Das folgende Beispiel stammt aus dem Bereich der Elektrotechnik. Die Techniken können auf ähnliche Weise in anderen Fach- und Arbeitsgebieten eingesetzt werden.

 

Einstellungen

Tutorial.mkd

 

Grundlagen

Ein Schaltplan besteht zum Großteil aus häufig auftretenden Bauteilen, die, wenn sie erst einmal erstellt sind, in verschiedensten Zeichnungen weitere Verwendung finden. In Bild 1 sind die verwendeten Bauteile farblich hervorgehoben.

 

 

Bild 1

 

Um die Bauteile möglichst universell zu gestalten, ist es zweckmäßig, bei ihrer Gestaltung bestimmte Normen einzuhalten, die den späteren Einsatz erleichtern. Die DIN legt hier zum Beispiel ein Rastermaß für Bauteile fest, auf dessen Grundlage die Elemente erstellt werden. In diesem Beispiel soll für Bauteile ein Rastermaß von M=2 mm zugrunde gelegt werden. Um Bauteile universell auf diesem Raster zu erstellen, sollten die Anschlusspunkte immer auf einem Rastermaß von 2M (also 4 mm) liegen.

 

Vorbereitungen

Bevor Sie mit dem Zeichnen beginnen, schalten Sie das Anzeigeraster mit der Taste F3 oder dem Taster in der Leiste ein. Bestimmen Sie das Rastermaß mit 4 mm, so wird nur jeder zweite Punkt, auf dem das Fadenkreuz "einrastet", angezeigt. Das Rastermaß kann in einem Dialogfeld eingestellt werden, das man mit dem Befehl Verwalten > Koordinatensysteme > Editieren - "Anzeigeraster" oder durch Klicken mit der rechten Maustaste auf dem entsprechenden Taster in der Leiste erhält. Der Rasterabstand von 2M für das Anzeigeraster hat den Vorteil, dass der Bildschirmaufbau schneller vonstatten geht und Sie außerdem genau erkennen können, auf welchen Punkten die Bauteilanschlüsse enden sollen. Schalten Sie zusätzlich mit der Taste F4 oder dem Taster auf der Leiste das Positionsraster ein. Dies sollte auf 2 mm Rastermaß festgelegt werden. Das Positionsraster lässt sich in einem Dialogfeld festlegen, das mit dem Befehl Verwalten > Koordinatensysteme > Editieren - "Positionsraster" oder ebenfalls durch Klicken mit der rechten Maustaste auf dem entsprechenden Taster in der Leiste aufgerufen werden kann.

 

Beginnen Sie damit, eine neue Bibliothek zu erstellen. Mit dem Befehl Bibliothek > Bibliotheken verwalten erhalten Sie ein Dialogfeld auf dem Bildschirm. Klicken Sie auf den Taster "Neu..." und geben Sie in dem Dateiauswahlfeld als Bibliotheksnamen Elektro.mkl ein. Nachdem Sie das Feld mit dem Taster "OK" geschlossen haben, geben Sie als Titel für die Bibliothek Elektronikbibliothek ein. Dieser Titel erscheint später in der Bibliotheksliste. Nun finden Sie die neue Bibliothek in der Bibliotheksliste wieder. Hier steht noch ein "N" vor dem Namen. Das liegt daran, dass die Bibliothek erst beim Verlassen des Dialogfeldes erstellt wird. Das "N" (Neu) vor dem Namen soll Sie daran erinnern. Verlassen Sie den Dialog mit dem Taster "OK". Die neue Bibliothek ist nun angelegt, aber noch leer.

 

Für die weitere Bearbeitung der Bauteile sollten Sie eine passende Vergrößerungsstufe wählen, die Ihnen das zu erstellende Bauteil in ausreichender Größe darstellt. Empfehlenswert ist zum Beispiel ein Zoomfaktor von 4.

 

Unser einfacher Schaltplan enthält vier prinzipiell verschiedene Bibliothekselemente. Dies sind Widerstände, Kondensatoren, Transistoren und Kontaktpunkte. Beginnen Sie mit dem einfachsten Bauteil.

 

Widerstand

 

 

Bild 2

 

Der Widerstand besteht aus einem Rechteck und zwei kurzen Linien. Die Abmessungen entnehmen Sie dem Bild. Sie brauchen hier keine Fangfunktion einzusetzen, da das Positionsraster aktiv ist. Das Fadenkreuz kann sich immer nur in 2 mm Abständen horizontal und vertikal bewegen. Jeder angezeigte Rasterpunkt auf dem Bild hat vom nächsten Rasterpunkt einen Abstand von 4 mm, da das Anzeigeraster auf 4 mm eingestellt ist.

 

Wenn Sie den Widerstand aus drei Objekten gezeichnet haben, lesen Sie den Block "Widerstand" mit dem Befehl Bibliothek > Block > Erzeugen (Einsetzpunkt) ein. Dazu identifizieren Sie alle Objekte und klicken für den Einsetzpunkt den linken Anschlusspunkt E an. Wählen Sie in dem erscheinenden Dialogfeld zuerst unter "Pfad" die vorher neu errichtete Bibliothek "Elektronikbibliothek" an. Geben Sie nun als Bauteilnamen Widerstand ein und verlassen Sie den Dialog mit dem Taster "OK". Damit ist das erste Bauteil in der Bibliothek abgelegt.

 

Kondensator

 

 

Bild 3

 

Auch der Kondensator ist ein relativ einfach zu zeichnendes Objekt aus drei Linien und einem Rechteck. Entnehmen Sie die Abmessungen bitte dem Bild. Achten Sie darauf, dass alle Anschlüsse auf einem Rasterpunkt enden. Verfahren Sie zum Einlesen in die Bibliothek bei dem Kondensator genauso wie bei dem Widerstand. Der Einsetzpunkt liegt ebenfalls an dem mit E gekennzeichneten Linienelement. Als Name dieses Blockes geben Sie Kondensator ein.

 

Transistor

 

 

Bild 4

 

Bei dem Transistor beginnen Sie mit den Anschlüssen. Die Linie mit dem Pfeil wird mit dem Befehl Beschriften > Maßlinie > Gerade erzeugt. Achten Sie darauf, dass in dem Maßlinienparameterdialogfeld (erreichbar mit UMSCH+ESC) bei der Ausrichtung der Maßlinie die Einstellung "nicht gedreht" aktiv ist, da sonst der Maßpfeil von der falschen Richtung aus gezeichnet wird. Zum Schluss zeichnen Sie den umgebenden Kreis mit dem Befehl Zeichnen > Kreis > Mitte - Punkt auf Kreis. Der Mittelpunkt des Kreises liegt auf dem mit M gekennzeichneten Anzeigerasterpunkt in Bild 4.

 

Radius für den Kreis ist der Endpunkt (Pfeilspitze) der geraden Maßlinie. Wählen Sie auch bei dem Transistor als Einsetzpunkt den linken Anschluss E und verfahren Sie ansonsten beim Einlesen des Bauteils wie bei dem Widerstand. Um Verwechselungen mit anderen Transistoren, die vielleicht später der Bibliothek hinzugefügt werden, auszuschließen, trägt das Bauteil die Bezeichnung NPN-Transistor.

 

Kontaktpunkte

 

 

Bild 5

 

Der Kontaktpunkt ist ein Kreis mit 0,5 mm Radius. Zeichnen Sie ihn auf einem Rasterpunkt mit dem Befehl Zeichnen > Kreis > Mitte - Punkt auf Kreis und geben Sie den Radius ein, indem Sie mit der Taste F8 (oder EINGABE) die Direkteingabe aufrufen. Legen Sie dieses Objekt unter dem Namen Kontaktpunkt offen ab.

 

Nun ändern Sie die Merkmale des Kreises, indem Sie mit dem Befehl Gestalten > Objektmerkmale > Ändern den Füllmodus auf "Füllung" setzen (Bild 6).

 

 

Bild 6

 

Dieses Objekt wird unter dem Namen Kontaktpunkt geschlossen in der Bibliothek abgelegt. Der Einsetzpunkt sollte im Mittelpunkt des Kreises liegen.

 

Schaltung

Alle erforderlichen Bauteile liegen nun in der Bibliothek vor. Bevor Sie weiter zeichnen, sollten Sie die erstellten Blöcke abspeichern. Wählen Sie dazu den Befehl Bibliothek > Bibliotheken verwalten. Selektieren Sie in dem Dialogfeld zuerst die zu speichernde Datei, also "Elektronikbibliothek", und betätigen Sie danach den Taster "Speichern". Vor dem Titel der Bibliothek wird nun ein "S" angezeigt. Verlassen Sie den Dialog mit dem Taster "OK". Das Speichern der Bibliothek wird nach dem Verlassen des Feldes ausgeführt.

 

Mit dem Befehl Datei > Neue Zeichnung beginnen Sie Ihren Schaltplan. Aktivieren Sie die Positions- und Anzeigeraster mit den gleichen Werten wie bei der Erstellung der Bauteile (2 mm Positionsraster und 4 mm Anzeigeraster). Wählen Sie das Blattformat DIN A4 quer mit dem Befehl Verwalten > Seiten > Editieren und schalten Sie den Zoomfaktor 2 mit dem Befehl Verwalten > Zoom > Faktor ein.

 

Auch wenn es der hier vorgestellte Schaltplan nicht erfordert, da er nicht ausgesprochen komplex ist, soll hier trotzdem das Arbeiten mit dem Blockfenster vorgestellt werden. Wählen Sie den Befehl Fenster > Blockfenster an/aus. Auf der rechten Seite Ihres Bildschirms sollte jetzt das Blockfenster eingeblendet sein. Hier lassen sich häufig gebrauchte Blöcke ablegen. Sie können dann durch einfaches Anklicken des entsprechenden Tasters im Blockfenster aktiviert werden, ähnlich wie ein Befehl aus dem Werkzeugfenster.

 

 

Um einen Block ins Blockfenster einzufügen, betätigen Sie auf einem Tasterfeld die rechte Maustaste. Jetzt erscheint ein Dialogfeld, das dem Dialogfeld bei Wahl des Befehls Bibliothek > Block > Einsetzen gleicht. Hier wählen Sie zunächst die gewünschte Bibliothek an. Dann klicken Sie auf den Namen des Blockes und entscheiden sich für einen Drehwinkel sowie einen Vergrößerungsfaktor. Da die soeben erstellte Bibliothek alle Bauteile bereits in der richtigen Vergrößerungsstufe enthält, interessiert hier nur der notwendige Drehwinkel. Beginnen Sie mit dem Transistor, ohne den Drehwinkel zu verändern und verlassen Sie den Dialog mit dem "OK" Taster. Der Block "Transistor NPN" sollte nun im Blockfenster erscheinen. Verfahren Sie genauso mit den anderen Bauteilen. Legen Sie den Widerstand ein weiteres Mal um 90° gedreht auf das Blockfenster. Sollte der Drehwinkel der Blöcke nicht angezeigt werden, so können Sie dies mit Rechtsklick auf das Fenster im erscheinenden Menü einstellen.

 

Zu Beginn positionieren Sie am besten die "komplexeren" Bauteile. In dem vorgestellten Schaltplan ist dies einer der beiden Transistoren. Nehmen Sie zuerst den Transistor V1. Klicken Sie im Blockfenster auf den Block für Transistor. Das Bauteil "hängt" jetzt am Fadenkreuz. Das Zentrum des Fadenkreuzes liegt im Einsetzpunkt. Mit aktivem Raster haben Sie so die Garantie, dass der Block beim Absetzen mit dem Einsetzpunkt auf einem Rasterpunkt endet. Platzieren Sie das Bauteil nun durch Drücken der linken Maustaste.

 

Wählen Sie jetzt den Block "Widerstand" in der senkrechten Ausführung und platzieren Sie den Block zweimal auf einer Höhe auf dem Arbeitsblatt - hier hilft Ihnen das Fadenkreuz - mit dem oberen und unteren Anschlusspunkt des Transistors (Widerstände R1 und R5). Geben Sie zunächst die ungefähre vertikale Position vor, da sich die Objekte sehr einfach mit dem Befehl Gestalten > Objekte bewegen > Strecke verschieben lassen. Auch hier profitieren Sie wieder von dem eingeschalteten Raster, da jede Bewegung auf dem Raster stattfindet und auf diese Weise auf Fangfunktionen verzichtet werden kann. Positionieren Sie auf die gleiche Weise den Kondensator C1.

 

Legen Sie jetzt den Transistor V2 auf seine ungefähre Position. Der Einsetzpunkt sollte etwas höher als der obere Anschlusspunkt von V1 liegen und zwischen V1 und V2 sollte genug Platz für R4 und C3 bleiben. Die Widerstände R2 und R6 werden ähnlich wie schon R1 und R5 ausgerichtet. Legen Sie nun die horizontalen Widerstände R3 und R4 in der Zeichnung an. Sie haben bereits einen entsprechenden Block, der um 90° gedreht ist, im Blockfenster abgelegt.

 

Die beiden Kondensatoren C3 und C2 sind um 90° und 180° gedreht und liegen so nicht im Blockfenster vor. Wählen Sie den Befehl Bibliothek > Block > Einsetzen und wählen als Pfad die Bibliothek "Elektronikbibliothek" aus. Klicken Sie auf den Block "Kondensator" und wählen als Drehwinkel 90° über den entsprechenden Taster an. Bestätigen Sie den Dialog mit "OK". Der Block steht Ihnen jetzt mit dem gewünschten Drehwinkel zur Verfügung. Setzen Sie ihn an der entsprechenden Stelle ein und verfahren Sie mit dem zweiten Kondensator (Drehwinkel 180°) genauso (Bild 7).

 

 

Bild 7

 

Mit dem Befehl Zeichnen > Linie > Linienzug / Kurve lassen sich auch Verbindungen über Ecken, wie zum Beispiel von V1 nach R3, sehr einfach auf dem Raster zeichnen. Andere, kurze Verbindungen ohne Ecken können mit dem Befehl Zeichnen > Linie > Punkt - Punkt erzeugt werden.

 

 

Bild 8

 

Bedenken Sie, dass es sich bei einem Linienzug um eine Kurve handelt, die nicht mit allen Funktionen bearbeitet werden kann. Um eine Bearbeitung zu ermöglichen, ist es manchmal erforderlich, die Kurve vor der Bearbeitung mit dem Befehl Trimmen > Objekt trimmen > Komplett zerlegen in einzelne Linien aufzulösen.

 

Jetzt setzen Sie mit dem Block "Kontaktpunkt geschlossen" die Verbindungspunkte an den einzelnen Kontaktstellen der Stromläufe. Zusätzlich wird an die Anschlusspunkte von C1 und C2 ein "Kontaktpunkt offen" auf das jeweils freie Ende gesetzt.

 

Zum Schluss fügen Sie noch die Beschriftung der einzelnen Bauteile an. Dies geschieht mit dem Befehl Beschriften > Text > Standard. Im Beispiel wurde die Schrift "Times New Roman" mit einer Schrifthöhe von 4,0 mm gewählt.

 

Um Sonderzeichen eines Zeichensatzes in den Text zu bekommen, können Sie entweder bei gedrückter Taste ALT auf der numerischen Tastatur den ANSI-Code des entsprechenden Zeichens eintippen und dann die Taste ALT wieder loslassen oder Sie starten aus der Windows Hauptgruppe das Programm "Zeichensatz", wählen aus Ihrem Zeichensatz das gewünschte Zeichen aus, kopieren es in die Zwischenablage und können es dann in Malz++Kassner CAD6 im Textfeld mit den Tasten STRG+V (oder STRG+EINFG) einfügen. Dies ist zum Beispiel bei dem Mikro-Zeichen in der Beschriftung für Kondensatoren erforderlich.

 

 

Bild 9

 

Am Schluss dieses Beispiels soll die Arbeitsweise von Bibliotheken noch einmal anhand einiger Veränderungen deutlich gemacht werden. Sichern Sie vor den weiteren Übungen Ihr Schaltbild unter dem Namen Schaltplan.mkd mit dem Befehl Datei > Zeichnung speichern unter.

 

Aktualisierungen

Ein wesentlicher Vorteil beim Einsatz von Bibliotheken liegt in der leichten Wartbarkeit von Zeichnungen. Sollten sich Blöcke nach dem Erstellen einer Bibliothek ändern, bewirkt die Aktualisierung des Blockes in der Bibliothek eine automatische Anpassung aller Zeichnungen, in denen dieser Block vorkommt. Testen Sie dieses anhand der erstellten Bibliothek. Vorher legen Sie sich jedoch eine Kopie der bestehenden Bibliothek "Elektronikbibliothek" mit der Bezeichnung Elektronikbibliothek Kopie an. Wählen Sie dazu den Befehl Bibliothek > Bibliotheken verwalten - "Speichern als". Sie können später den Vorgang des Kopierens umkehren (also die Kopie wieder auf das Original kopieren) und so die Bibliothek immer wieder mit der Kopie restaurieren. Beginnen Sie nun die folgenden Übungen mit einem neuen Arbeitsblatt (Datei > Neue Zeichnung).

 

Es gibt prinzipiell zwei verschiedene Wege, neue oder geänderte Blöcke in einer Bibliothek aufzunehmen, die in bereits existierenden Zeichnungen Blöcke ersetzen sollen.

 

Möglichkeit 1

Der geänderte Block wird unter einem neuen, aktualisierten Namen angelegt. Dieses Verfahren ermöglicht Ihnen, nur die Blöcke in den jeweiligen Zeichnungen zu aktualisieren, bei denen der Austausch auch wirklich erwünscht ist. Dies sollte aus Sicherheitsgründen der übliche Weg sein. Nachteil des Verfahrens ist ein erhöhter Aufwand, da in jeder Zeichnung der Befehl zum Austauschen des Blockes mit einem anderen Block erfolgen muss.

 

Ändert sich in dem Fallbeispiel die Norm für die Darstellung eines Transistors, so wäre eine entsprechende Änderung auch in der Bibliothek erforderlich. Die neue Darstellungsform des Transistors soll sich von der alten Darstellung dadurch unterscheiden, dass der umgebende Kreis fehlt. Um die Darstellung zu ändern, setzen Sie einen Block "Transistor" auf Ihrem Arbeitsblatt ein und lösen es mit dem Befehl Bibliothek > Block > Blockinstanzen auflösen in Objekte auf. Löschen Sie den Kreis mit dem Befehl Gestalten > Objekte löschen (oder Taste ENTF). Der geänderte Block kann jetzt wieder mit dem Befehl Bibliothek > Block > Erzeugen (Einsetzpunkt) in die Bibliothek "Elektronikbibliothek" eingefügt werden. Sollten Sie das Raster nicht aktiviert haben, so fangen Sie den Einsetzpunkt am linken Anschluss mit dem Fangmodus "Eck-/Endpunkt". Geben Sie dem Block den Namen NPN-Transistor (neu), um ihn von der alten Version zu unterscheiden. Speichern Sie die Bibliothek in der geänderten Fassung mit dem Befehl Bibliothek > Bibliotheken verwalten und wählen Sie in dem Dialogfeld "Speichern" an.

 

Laden Sie Ihre Zeichnung Schaltplan.mkd. Mit dem Befehl Bibliothek > Block ersetzen können Sie nun bestimmen, welcher Block in der geladenen Zeichnung gegen einen anderen Block ausgetauscht werden soll. Die gewünschten Blöcke werden ausgewählt, indem Sie auf den Taster "Wählen" klicken und dann in dem Bibliotheksdialogfeld jeweils die gewünschten Blöcke aussuchen. Automatisch werden alle Blöcke in der Zeichnung mit der alten Bezeichnung gegen Blöcke mit der neuen Bezeichnung ausgetauscht. Auf Wunsch kann diese Operation auch nur auf dauerhaft gewählte Objekte beschränkt werden. Klicken Sie dazu auf das mit "Nur permanente Auswahl" bezeichnete Markierungsfeld.

 

Möglichkeit 2

Der zweite Weg ist das direkte Überschreiben des alten Blocks mit dem geänderten neuen Block. Dieses Verfahren birgt das Risiko in sich, auch Blöcke, die nicht geändert werden sollen, mit zu verändern. Ein Vorteil ist, dass jede Zeichnung mit dem neuen Block ohne Eingriff in die Zeichnung sofort in der neuen, aktualisierten Fassung vorliegt.

 

Für diesen Weg gehen Sie analog zum vorherigen Beispiel vor, nur wird der Block unter dem Namen des bereits existierenden Blocks eingelesen (also NPN-Transistor). Das Ersetzen des Blocks entfällt. Nach dem Laden der Zeichnung werden Sie feststellen, dass der Block bereits in geänderter Fassung in der Zeichnung vorkommt.

 

Wandeln

Entfernen Sie nun die Bibliothek "Elektronikbibliothek" aus dem Speicher, indem Sie in dem Dialogfeld Bibliothek > Bibliotheken verwalten auf den Taster "Entfernen" klicken und den Dialog mit "OK" wieder verlassen. Auf dem Schirm wird Ihnen für jeden Block nun die Bibliothek und der Blockname angezeigt, da das Programm keinen Zugriff mehr auf die entsprechenden Blöcke hat. Der Schaltplan kann ohne die Bibliothek nicht mehr korrekt ausgegeben werden, weil nur die Verweise auf die Originalblöcke in der Bibliothek bestehen. Nach dem Laden der Bibliothek (Bibliothek > Bibliotheken verwalten - "Öffnen") werden die Blöcke wieder korrekt dargestellt.

 

Sie können die Zeichnung nun bibliotheksunabhängig machen, indem Sie entweder mit dem Befehl Bibliothek > Externe Blöcke in interne wandeln alle externen Blöcke in interne wandeln oder mit dem Befehl Bibliothek > Block > Blockinstanzen auflösen aus den Blöcken wieder Objekte machen.

 

Das Wandeln der externen Blöcke in interne hat den Vorteil, dass alle Instanzen erhalten bleiben und die Blöcke mit der Zeichnung gespeichert werden. Wandeln Sie die externen Blöcke in interne und entfernen Sie danach noch einmal die Bibliothek. Wie zu erwarten, bleibt die Zeichnung nun im Ursprungszustand. Die Blöcke liegen nach dem Speichern der Zeichnung bibliotheksunabhängig in der Zeichnung vor.

 

Attribute

Jeder Block kann verschiedene Eigenschaften oder auch Attribute tragen. Diese Eigenschaften eines Blocks können für alle Bauteile gleich sein oder aber individuell von eingesetztem Bauteil zu Bauteil unterschiedlich. Malz++Kassner CAD6 bietet die Möglichkeit, solche Attribute den Blöcken zuzuordnen und diese dann später in einer Stückliste auszugeben. Attribute, die sich bei einem Block nicht ändern, werden globale Attribute genannt. Individuelle Eigenschaften, die zum Zeitpunkt des Einsetzens eines Block in die Zeichnung erst festgelegt werden, bezeichnet man als lokale Attribute. Attribute sollten beim Einlesen eines Blocks in die Bibliothek festgelegt werden.

 

CAD6studio Release 2024.0 - Copyright 2024 Malz++Kassner® GmbH