Objekte verändern (Einführung)

www.CAD6.de

In diesem Kapitel werden Objekte behandelt, die bereits erzeugt worden sind und im Nachhinein verändert werden sollen. Unabhängig von dem Befehl, der das Objekt verändern soll, sind einige grundlegende Vorgehensweisen zu beachten. Wie bereits in der Befehle in CAD6 wählen beschrieben, wird vor der Auswahl des Objektes einmal der Befehl ausgewählt, der für die weitere Bearbeitung verwendet werden soll. Erst dann wird das Objekt bzw. die Objekte ausgewählt.

 

Objektauswahl

Die Objektauswahl kann in unterschiedlicher Art und Weise geschehen und hängt stark von der jeweiligen Anwendung ab. Im Folgenden werden die Objektauswahl-Mechanismen exemplarisch erläutert.

 

Parallel zu diesem Kapitel sollte CAD6 geöffnet sein und die Beispiele praktisch nachverfolgt werden. Dazu sollten eine Reihe von Objekten willkürlich auf dem Bildschirm  verteilt werden, welche exemplarisch ausgewählt werden können. Die aktuelle Objektauswahl kann jederzeit mit der ESC-Taste oder einem Rechtsklick abgebrochen werden.

 

Auswahl eines einzelnen Objektes

Ein einzelnes Objekt wird durch einen Linksklick mit der Maus ausgewählt.

 

Auswahl mehrerer Objekte

Durch ständiges Halten der STRG-Taste ist es möglich, mehrere Objekte durch Linksklick mit der Maus auszuwählen. Soll die Auswahl eines einzelnen Objektes wieder zurückgenommen werden, ist lediglich ein erneutes Anklicken notwendig. Erst durch Lösen der STRG-Taste wird die Objektauswahl beendet.

 

Objekte vor und nach der Auswahl

 

Auswahl von Objekten eines Bereiches

Wird die UMSCHALT-Taste gedrückt gehalten, kann mit der Maus ein rechteckiger Bereich aufgezogen werden, indem alle Objekte ausgewählt werden. Voraussetzung ist allerdings, dass die Objekte vollständig in diesem Bereich liegen, d.h. nicht aus ihm herausragen.

 

Auswahl von Objekten in Gruppen

Wird die ALT-Taste gedrückt gehalten, können mit der Maus einzelne Objekte innerhalb von Gruppen gewählt werden. Wird gleichzeitig die UMSCH- bzw. STRG-Taste gedrückt gehalten, kann dies auch mit der Auswahl anderer Objekte und ganzer Bereiche kombiniert werden.

 

Auswahl aller Objekte

Mit Extra > Auswahl > Alles Auswählen oder durch Drücken der Taste "F10" können alle Objekte gleichzeitig gewählt werden.

 

Auswahl aller vorherigen Objekte

Mit Extra > Auswahl > Vorherige Auswahl oder durch Drücken der Taste "F11" können alle Objekte gleichzeitig gewählt werden, die im letzten Arbeitsschritt markiert worden waren.

 

Um den Nutzen dieser Funktion zu verdeutlichen, sei ein kleines Beispiel gegeben. Es sollen eine Vielzahl von Objekten zu einem Block zusammengefasst werden. Dazu wird der Befehl Bibliothek > Block > Erzeugen (Einsetzpunkt) gewählt, die Objekte markiert und ein Bezugspunkt eingegeben. Möchte man nun die gewählten Einzelobjekte des Blockes nach der Erzeugung löschen, so muss man nur noch den Befehl Gestalten > Objekte löschen wählen und mit Drücken der Taste "F11" die Objekte wählen, die bei dem vorherigen Befehl markiert waren. Es ist also keine erneute Auswahl notwendig.

 

Auswahl einzelner Objekte löschen

Behält man bei oberen Methoden die STRG-Taste zusätzlich gedrückt, kann die Auswahl von einzelnen Objekten durch Linksklick wieder zurückgenommen bzw. ergänzt werden. Dies ist solange möglich, wie die STRG-Taste gedrückt bleibt.

 

Punktauswahl

Bei der sogenannten Punktauswahl können einzelne Punkte eines Objektes bewegt werden. Dies bewirkt im allgemeinen einen Streckungs- oder Stauchungseffekt des Objektes. In der folgenden Abbildung wurden exemplarisch mit dem Menübefehl Gestalten > Punktmenge bewegen > Strecke von einfachen Objekten Eckpunkte bewegt (blau markiert).

 

Streckungs- und Stauchungseffekte durch Bewegen von Punkten

 

Je nach Anwendung stellt CAD6 verschiedene Befehle zur Verfügung, um einzelne oder mehrere Definitionspunkte zu verschieben:

 

Gestalten > Punktmenge bewegen > Strecke

Die Verschiebung der Definitionspunkte wird über die Eingabe eines Bezugspunktes und eines Zielpunktes realisiert.

 

Gestalten > Punktmenge bewegen > Lotrecht bzw. Parallel

Die Verschiebung der Definitionspunkte findet lotrecht bzw. parallel zu einem angegebenen Bezugsobjekt statt.

 

Gestalten > Punktmenge bewegen > Relative Werte

Die Verschiebung der Definitionspunkte findet um einen numerisch eingegebenen, relativen Wert statt.

 

Gestalten > Punktmenge bewegen > Einzelnen Punkt

Mit diesem Befehl können einzelne Definitionspunkte von Objekten verschoben werden. Auf diese Weise können Manipulation an Objekten vorgenommen werden, die mit "normalen" Gestaltungsfunktionen wie Bewegen und Drehen nicht möglich wären.

 

Permanente Auswahl

Objekte können permanent selektiert werden, d.h. eine Selektion bleibt solange bestehen, bis sie explizit aufgelöst wird.

 

Der Befehl Extra > Permanente Auswahl > Setzen ermöglicht die Auswahl von Objekten. Mit Extra > Permanente Auswahl > Löschen kann die Selektion einzelner Objekte wieder aufgehoben werden, bzw. mit "Alles Auswählen" (Taste "F10") die Selektion aller. Wählt man den Befehl Extra > Permanente Auswahl > Invertieren, kann die Selektion in den genau entgegengesetzten Zustand überführt werden.

 

Die permanente Auswahl hat zwei Nutzen: Zum einen kann auf diese Weise eine Menge von Objekten langfristig markiert werden. Mit Extra > Auswahl > Permanente Auswahl nutzen oder durch Drücken der Taste "F12" kann dann gezielt ein Befehl auf die permanent selektierten Objekte angewendet werden.

 

Eine weiteren Einsatz findet die permanente Auswahl von Objekten bei der Wiedergabe von Zeichnungseinstellungen (Verwalten > Zeichnungs-Einstellungen > Bildschirm). Dort können Einstellungen sowohl auf alle Objekte als auch nur auf permanent selektierte Objekte angewendet werden.

 

Bei einigen Befehlen, wird die permanente Selektion als zweite Objektauswahl neben der normalen, jeweils direkt ausgeführten Objektauswahl verwendet. Dies ist z.B. beim Befehl Objekte bewegen / kopieren > Mehrfachkopie, Markierungen der Fall.

 

Selektionsfilter

In sehr großen Zeichnungen, mit vielen verschiedenen und eng aneinander liegenden Objekten, kann die Selektion von einzelnen Objekten sich als sehr schwierig erweisen. Wenn alle diese Objekte allerdings vom gleichen Typ sind oder alle den gleichen Merkmalssatz besitzen, hat man die Möglichkeit, diese Objekte über ihre Gemeinsamkeiten zu erkennen und zu selektieren. Dies geschieht über den sogenannten Selektionsfilter. Um die Handhabung zu erläutern, sei ein kleines Beispiel gegeben:

 

Ausgangssituation: Sie haben von einem Kollegen eine Zeichnung bekommen, die Sie überarbeiten sollen. Die Zeichnung hat ca. 10.000 Objekte, wobei jeder Objekttyp verwendet wurde und Details nur jeweils in großen Zoomstufen zu erkennen sind. Sie bemerken, dass für einen bestimmten Linientypen ein falsches Linienmuster und eine falsche Objektfarbe verwendet worden ist. Dieser Linientyp kommt an unterschiedlichen Stellen ca. 150 mal vor.

 

Eine Möglichkeit, wenn auch eine sehr mühsame, wäre, jede dieser Linien einzeln zu wählen, um die Merkmale zu ändern. Sie werden allerdings feststellen, dass diese Form der Selektion sehr unpraktisch und unkomfortabel ist. Eine ideale Lösung in diesem Fall wäre es, mit einem Tastendruck alle Objekte dieses Merkmalstyp auswählen zu können.

 

Dies geschieht über den Selektionsfilter. Die gesamte Objektauswahl kann über den Merkmalssatz der Objekte gesteuert werden. Mit Extra > Selektionsfilter-Parameter kann der Filter eingestellt werden. Es erscheint folgender Dialog:

 

 

Für das oben genannte Beispiel würden die Einstellungen wie in obiger Abbildung vorgenommen werden. In diesem konkreten Fall würden also ausschließlich Linien ausgewählt werden, die das Muster "Strichlinie-Abstandlinie", die Linienstärke 0,25 mm und die Linienfarbe "blau" besitzen. Alle anderen Objekte würden von der Auswahl ausgeschlossen bleiben, sofern der Selektionsfilter aktiv ist, d.h. der Menüpunkt Extras > Selektionsfilter gewählt ist.

 

Möchte man z.B. die Merkmale dieser Objekte dahingehend ändern, dass das Linienmuster "Strich-Punktlinie", die Linienstärke "1.0 mm" und die Linienfarbe "rot" sein soll, würde man über den Befehl Gestalten > Objektmerkmale > Ändern die entsprechenden Einstellungen vornehmen und über Extra > Auswahl > Alles wählen nur die vom Selektionsfilter zugelassenen Objekte ändern. Nach einer solchen Änderung sollte der Selektionsfilter wieder ausgeschaltet werden, um bei späteren Selektionen wieder alle Objekte zu erhalten.

 

Merkmale ändern

Jedes Objekt besitzt einen sogenannten Merkmalssatz, bestehend u.a. aus Linienbreite, Linienmuster, Linienfarbe, Füllfarbe und Füllmodus. Diese Merkmale bestimmen das Aussehen des Objektes, sowohl auf dem Bildschirm als auch bei der Ausgabe. Der Merkmalssatz wird beim Erzeugen des Objektes mit angelegt und kann fortlaufend verändert werden.

 

Im Folgenden wird von direkten und indirekten Merkmalen gesprochen. Die direkten Merkmale sind die, die ein Objekt selber besitzt. Die indirekten Merkmale hingegen werden den Objektmerkmalen überlagert. Der Einfachheit halber werden zunächst erst einmal nur die direkten Merkmale behandelt und anhand eines kurzen Beispiels erläutert:

 

Mit dem Befehl Zeichnen > Linie > Punkt - Punkt wird eine Linie auf die Zeichenfläche gezeichnet. Wählt man dann Gestalten > Objektmerkmale > Ändern und selektiert die eben gezeichnete Linie, erscheint ein Dialog mit den Objektmerkmalen.

 

 

Die ersten drei Merkmale "Seite", "Ebene" und "Stift" können bei der Betrachtung der direkten Merkmale vernachlässigt werden. Die danach folgenden Merkmale beeinflussen die Erscheinung des Objektes direkt und können in diesem Dialog geändert werden. Um die Farbe der Füllung oder der Kontur zu ändern, muss das jeweilige Farbfeld mit der linken Maustaste angeklickt und in dem erscheinenden Farbauswahldialog die gewünschte Farbe eingestellt werden. Nach dem Verlassen des Dialoges mit "OK" werden alle Einstellungen auf das Objekt angewendet.

 

Jedem Merkmal ist ein sogenanntes "Fixieren"-Merkmal zugehörig, welches gesetzt werden muss, um das jeweilige Merkmal vor einer Überlagerung, also vor einer indirekten Einflussnahme von außen, zu sperren. In unserem Beispiel werden der Stift, die Linienfarbe und die Linienstärke geändert.

 

 

Eine weitere Möglichkeit, die Merkmale eines Objektes zu bestimmen, ist der Weg über die indirekten Merkmale. Dieser Weg ist zunächst komplizierter. Hat man ihn aber erst verinnerlicht, ist der Umgang mit dieser Art von Merkmalsübertragung in vielen Bereichen flexibler und effizienter. Merkmale können indirekt auf zweierlei Arten in das Objekt gelangen:

 

Ebenen

Jedes Objekt enthält in seinen Merkmalen einen Verweis auf eine Ebene, in der es sich befindet. Eine Ebene hat jeweils den gleichen Merkmalssatz wie jedes andere Objekt auch. Die Merkmale eines Objektes hängen also nicht nur von seinen eigenen Merkmalen ab, sondern auch von den vererbten Merkmalen der zugeordneten Ebene.

 

Die Merkmale einer Ebene verändern nicht den Merkmalssatz eines Objektes, es findet lediglich eine Überlagerung statt. Das bedeutet, dass durch Änderungen der Merkmale einer Ebene sich die Darstellung der Objekte ändert, die sich in dieser Ebene befinden. Es muss deutlich werden, dass sich lediglich die Darstellung der Objekte ändert und nicht deren Merkmalssätze, d.h. dass z.B. die Linienfarbe eines Objektes von den Merkmalen der Ebene abhängt und nicht von den Merkmalen des Objektes. Man spricht in diesem Fall von einer Merkmalsvererbung.

 

Möchte man allerdings für die Darstellung die Merkmale des Objektes selber nutzen, kann man die Vererbung der Ebene sperren. Dies geschieht im Merkmalssatz des jeweiligen Objektes, indem im Dialog zu Gestalten > Objektmerkmale > Ändern das Feld "Fixieren" des zu sperrenden Merkmals markiert wird.

 

Bildschirmmerkmale und Ausgabemerkmale einer Ebene

Eine Ebene besitzt zwei Merkmalssätze, einen für die Anzeige auf dem Bildschirm und einen anderen für die Ausgabe (z.B. Drucker). Beide können einem Objekt zugeordnet werden, so dass ein Objekt durchaus auf dem Bildschirm mit anderen Merkmalen erscheinen kann als später bei der Ausgabe auf einem Drucker. Die Trennung der Merkmale ist z.B. dann sinnvoll, wenn man auf dem Bildschirm farbig arbeiten möchte und als Ausgabegerät nur ein Schwarz/Weiß-Plotter zur Verfügung hat.

 

Bearbeiten einer Ebene

Mit Verwalten > Ebenen > Editieren kann der Ebenendialog mit einer Liste der vordefinierten und benutzerdefinierten Ebenen geöffnet werden.

 

 

Wird eine Ebene in der Liste markiert, erscheinen in dem unteren Textfeld die Merkmale, die an alle in dieser Ebene befindlichen Objekte vererbt werden, sofern diese sich nicht gegen die Vererbung sperren.

 

Anzeigen/Ausgeben der Ebene

Ebenen können sowohl für die Bildschirmdarstellung als auch für die Ausgabe ausgeschaltet werden. Alle Objekte dieser Ebene werden dann nicht mehr angezeigt, bzw. ausgegeben. Um die Ebenen aus- bzw. anzuschalten müssen die Felder "Anzeigen" und "Ausgeben" entsprechend markiert werden. Die Markierung gilt für die jeweils gewählte Ebene. Zur besseren Übersicht zeigen Symbole vor den Ebenennamen, ob eine Ebene angezeigt, bzw. ausgegeben wird. Das Symbol "Sonne" zeigt an, dass die Ebene auf dem Bildschirm angezeigt wird und das Symbol "Drucker" zeigt an, dass die Ebene ausgegeben wird.

 

Anlegen einer neuen Ebene

Durch Drücken des Tasters "Neu" kann der Name einer neuen Ebene definiert werden. Will man eine Ordnerstruktur aufbauen, muss für einen Unterordner die Eingabe "Ordner\" erfolgen, also z.B. "Neuer Ordner\Neue Ebene" als Ebenenname.

 

Merkmalssatz der Ebene festlegen

Durch Drücken des Tasters "Bildschirm" bzw. "Ausgabe" erscheint der Dialog "Merkmale editieren". Dort können, wie oben beschrieben, die Merkmale der Ebene editiert werden. Möchte man diese an die Objekte vererben, muss das entsprechende "Vererben"-Merkmal gesetzt werden.

 

Um die Übersicht zu erleichtern, können die Bildschirmmerkmale mit den Ausgabemerkmalen gleichgesetzt werden, so dass es nur noch einen Merkmalssatz zu verwalten gibt. Dazu wird das Feld "Merkmale für Bildschirm und Ausgabe identisch" markiert und in dem erscheinenden Dialog der Merkmalssatz gewählt, der beibehalten werden soll.

 

Alle Änderungen der Ebeneneinstellungen werden durch Drücken des Tasters "Übernehmen" aktiv oder indem der Dialog mit dem Taster "Schließen" verlassen wird.

 

Stifte

Bei den Stiften verhält es sich ähnlich wie bei den Ebenen. Ein Stift besitzt ebenfalls einen Bildschirm- und Ausgabemerkmalssatz. Der Unterschied zu einer Ebene ist allerdings, dass Stifte keine einzelnen Merkmale vererben. Es ist vielmehr so, dass das Objekt die Merkmale eines Stiftes übernimmt. Auch hier kann sich das Objekt durch das Fixieren der Merkmale dagegen sperren.

 

Mit Verwalten > Stifte > Editieren können ähnlich wie bei den Ebenen Einstellungen vorgenommen werden. Ein wesentlicher Unterschied zu den Ebenen besteht darin, dass bei den Merkmalen kein "Vererben"-Merkmal gesetzt werden kann. Dies ist bei den Stiften nicht nötig, da die Objekte sich die Merkmale sozusagen selber holen und nicht vererbt bekommen müssen.

 

Seiten

Indem Objekte bestimmten Seiten zugewiesen werden, sind sie nur sichtbar bzw. werden sie nur ausgedruckt, wenn die zugeordnete Seite aktiv ist. Damit lassen sich z.B. unterschiedliche, sich überlappende Zeichnungsrahmen verwalten.

 

Objekte bearbeiten

Weiter oben wurde beschrieben, wie die Merkmale eines Objektes, wie z.B. die Farbe, der Linienstil o.ä. verändert werden können. Objekte können aber auch in ihren geometrischen Eigenschaften verändert werden, wie z.B. in der Größe und der Position. Hierzu stehen eine Vielzahl von Funktionen zur Verfügung. Im Folgenden werden einige der Standardbefehle kurz vorgestellt. Es ist wieder zu beachten, dass der jeweilige Befehl als erstes auszuwählen ist, bevor mit der Auswahl der Objekte begonnen wird.

 

Die Standardbefehle zur Objektbearbeitung stehen im Menü Gestalten > Objekte... und untergliedern sich wie folgt:

 

...löschen

Mit diesem Befehl können gewählte Objekte und Instanzen der Zeichnung gelöscht werden.

 

...bearbeiten

Mit diesem Befehl können Objekte und Instanzen direkt mit der Maus bearbeitet werden. Dazu stehen alle Grundoperationen wie Bewegen, Skalieren, Drehen und Verzerren zur Verfügung. Über die Symbole am Rand der Objektmarkierung können per Mausklick die gewünschten Befehle ausgeführt werden. Dabei wird das ungefähre Ergebnis dem Benutzer in einer Vorschau angezeigt. Der Befehl kann mit der rechten Maustaste oder mit Drücken der ESC-Taste abgebrochen werden.

 

 

...bewegen / kopieren > ...

Mit diesen Befehlen können Objekte und Instanzen der Zeichnung bewegt oder kopiert werden. Normalerweise wird bewegt, ist aber die Duplikatfunktion aktiv, werden die Objekte kopiert. Besonders interessant ist die Variante Relative Werte, mit der Objekte um definierte Distanzen horizontal und/oder vertikal bewegt oder kopiert werden können.

 

...skalieren >...

Mit diesen Befehlen können Objekte und Instanzen der Zeichnung skaliert, d.h. in ihrer Größe verändert werden.

 

...drehen >...

Mit diesen Befehlen können Objekte und Instanzen der Zeichnung gedreht werden.

 

...spiegeln >...

Mit diesen Befehlen können Objekte und Instanzen der Zeichnung gespiegelt werden, unter anderem auch an beliebigen Geraden.

 

...verzerren >...

Mit diesem Befehl können Objekte und Instanzen der Zeichnung verzerrt (geschert) werden.

 

...ausrichten >...

Mit diesen Befehl können Objekte und Instanzen bezüglich des aktiven Blattrahmens, eines rechteckigen Rahmens oder einer Geraden zentriert oder ausgerichtet werden. Beim Zentrieren werden alle gewählten Objekte und Instanzen als Einheit behandelt, d.h. sie werden alle um den gleichen Betrag verschoben. Beim Ausrichten hingegen wird jedes gewählte Objekt und jede gewählte Instanz getrennt behandelt, d.h. wird um einen individuellen Betrag verschoben.

 

CAD6studio Release 2024.0 - Copyright 2024 Malz++Kassner® GmbH